Zur Navigation

Installation trotz Mod_rewrite nicht möglich

1 Schüler

Hallo Jörg,

erst mal vielen Dank für dieses tolle Forum. Also zumindest, was ich hier sehen kann entspricht wohl allen Anforderungen und mehr braucht man auch gar nicht.

Aber nun zu meiner eigentlichen Frage. Wenn ich das Forum installieren möchte, dann klappt das leider in meiner Weise. Ich habe über Parallels Confixx über Httpd spezial die Funktion mod_rewrite aktiviert, kann dennoch keine Installation vornehmen, was mache ich falsch?

Ich habe das Forum in einem Unterordner entpackt mit allen Dateien, die vorhanden sind. Habe auch in der .htaccess die Änderung vorgenommen und die Raute entfernt + /forum/ gesetzt. Aber es kommt dann auch immer nur Server Fehler 500 und wenn ich die .htaccess Datei entferne, dann ist mod_rewrite nicht aktiviert. Woran kann es also liegen?

Vielleicht können sie mir behilflich sein


Grüße

Markus

21.12.2013 10:24

2 Jörg

Habe auch in der .htaccess die Änderung vorgenommen und die Raute entfernt + /forum/ gesetzt.

Das heißt, du hast nur diese Zeile so geändert:

RewriteBase /forum/

... und das Forum soll dann über die URL http://example.com/forum/ aufrufbar sein?

Enthält die .htaccess Dateien noch weitere Änderungen, wenn ja welche?

Gab es bereits vor Änderung der .htaccess Datei einen Error 500 oder einen anderen Fehler?

Teste mal, ob mod_rewrite in diesem Verzeichnis generell möglich ist:

http://www.joergkrusesweb.de/lexikon/mod-rewrite

21.12.2013 10:54 | geändert: 21.12.2013 10:58

3 Schüler

Zitat von Jörg
Habe auch in der .htaccess die Änderung vorgenommen und die Raute entfernt + /forum/ gesetzt.

Das heißt, du hast nur diese Zeile so geändert:

RewriteBase /forum/

... und das Forum soll dann über die URL http://example.com/forum/ aufrufbar sein?

Enthält die .htaccess Dateien noch weitere Änderungen, wenn ja welche?

Gab es bereits vor Änderung der .htaccess Datei einen Error 500 oder einen anderen Fehler?

Teste mal, ob mod_rewrite in diesem Verzeichnis generell möglich ist:

http://www.joergkrusesweb.de/lexikon/mod-rewrite

Ich habe nun die Testdatei test.html mal mit sämltichen Zeilen der .htaccess ins Stammverzeichnis gelegt. Das hat auch soweit funktioniert mit der Weiterleitung. Aber auch erst mit dem Zusatz "Options +FollowSymlinks"

Trotzdem komme ich nicht weiter mit der Installation, da ich dort weiterhin nur entweder Error 500 angezeigt bekomme bei hochgeladener .htaccess Datei oder das mod_rewrite deaktiviert ist wenn ich die .htaccess Datei weglasse. Ich habe die Dateien so hochgeladen: STAMMVERZEICHNIS/forum/ Es macht keinen Unterschied ob ich die Raute weglasse, /forum/ schreib oder umgekehrt oder gar beides zusammen, der Fehler 500 bleibt bestehen.

Weitere Änderungen habe ich nicht vorgenommen.


Grüße

Markus

21.12.2013 11:30 | geändert: 21.12.2013 11:31

4 Jörg

Ich habe nun die Testdatei test.html mal mit sämltichen Zeilen der .htaccess ins Stammverzeichnis gelegt. Das hat auch soweit funktioniert mit der Weiterleitung. Aber auch erst mit dem Zusatz "Options +FollowSymlinks"

Funktioniert die .htaccess Datei mit folgendem Inhalt (ohne weitere Zeilen) denn auch in "STAMMVERZEICHNIS/forum/":

Options +FollowSymlinks

RewriteEngine on
RewriteRule test\.html http://example.com/ [R]

(hierbei http://deine-domain.com/forum/test.html aufrufen)

Falls nein, funktioniert diese:

Options +FollowSymlinks

RewriteEngine on
RewriteBase /forum/
RewriteRule test\.html http://example.com/ [R]

Bitte auch noch diese Frage beantworten:

Zitat von Jörg
... und das Forum soll dann über die URL http://example.com/forum/ aufrufbar sein?

("example.com" durch den Namen deiner Domain ersetzen)

21.12.2013 11:52 | geändert: 21.12.2013 11:57

5 Schüler

Hallo nochmals,

also mithilfe

Options +FollowSymlinks

RewriteEngine on
RewriteRule test\.html http://example.com/ [R]

funktioniert das auch unter http://www.meinedomain.de/forum/ mit der test.html. Und ja, das ganze soll unter http://meinedomain.de/forum/ aufrufbar sein. Ich merke nochmal nur zur Sicherheit an, das ich die .htaccess aus der tar.gz immer in das direkte Verzeichnis (http://.../forum/) gepackt habe oder ist das falsch?

21.12.2013 12:02

6 Jörg

Ja, die .htaccess Datei muss in dasselbe Verzeichnis wie die übrigen Dateien.

Die "Options +FollowSymlinks" muss dann wohl auch in die .htaccess Datei des Forums. Allerdings sollte ein Fehlen eigentlich einen Error 403 erzeugen.

Hast du Zugriff auf die Errorlog-Dateien des Webservers? dort wird meist auch der Grund für 500er Fehler aufgezeichnet.

Möglich wäre noch, dass der Inhalt der .htacess eines übergeordneten Verzeichnisses irgendwie dazwischen funkt. Falls es übergeordnete .htaccess Dateien gibt, könntest du mir diese zusenden (Email-Adresse in meinem Profil oder im Impressum), so dass ich die Konstellation selbst mal testen kann.

21.12.2013 12:19 | geändert: 21.12.2013 12:20

7 Schüler

Ich habe nun folgende Funktionen aktiv: WebServer mod_rewrite(on), WebServer error log(on)

Eigentlich soll ich nun ein Server Errorlog in dem Log-Verzeichnis bekommen, aber dort ist nur ein Zugriff-Log mit sämlichen Zugriffen aufgelistet. Ich warte noch mal ein paar Minuten, dauert wogl etwas bis das sich umstellt.

Wie gesgt, wenn ich die .htaccess Datei weglasse, sehe ich die Seite der Installation nur mit dem Hinweis

Installation des Forums

Fehler: Mod_rewrite funktioniert nicht.
Überprüfe, ob Mod_rewrite für deinen Webspace aktiviert ist.

Bei vorhandener .htaccess Datei hingehen weiterhin 500 Internal Server Error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Eine überordnete .htaccess Datei gibt übrigens es nicht im Stammverzeichnis. Ich meine den Fehler 403 hatte ich noch, wo WebServer mod_rewrite(on) noch nicht aktiviert war.


Als kleiner Nachtrag:

im Error Log steht nun:

[Sat Dec 21 12:47:41 2013] [alert] [client XXX.XXX.XXX.XXX] /var/www/web746/html/forum/.htaccess: Illegal option RewriteEngine

21.12.2013 12:43 | geändert: 21.12.2013 12:56

8 Jörg

[Sat Dec 21 12:47:41 2013] [alert] [client XXX.XXX.XXX.XXX] /var/www/web746/html/forum/.htaccess: Illegal option RewriteEngine

Die .htaccess Datei, die du hochgeladen hast, hattes du diese vorher mit einem Editor unter Windows bearbeitet? wenn ja, mit welchem Editor? Hier hatte jemand ein ähnliches Problem, das dadurch entstand, dass Windows-Umbrüche vom Server missverstanden wurden.

Problematisch sind auf jeden Fall Mischung von Windows- und UNIX-Umbrüchen. Notepad++ sollte soweit ich weiß, in der Lage sein, diese korrekt zu unterscheiden

Wichtig ist auch, dass das FTP-Programm eine .htaccess Datei im richtigen Modus (ASCII-Modus) hochlädt. Wobei Programme wie Filezilla eigentlich schon automatisch den korrekten Modus auswählen.

21.12.2013 13:16 | geändert: 21.12.2013 13:17

9 Schüler

Bei mir steht nun folgendes in der .htaccess Datei nach dem ich sie mit Notepad++ geöffnet habe

Options +FollowSymlinks

RewriteEngine on

RewriteBase /forum/RewriteCond %{QUERY_STRING} !^$
RewriteCond %{THE_REQUEST} /index\.php
RewriteRule ^index\.php$ - [G,L]

RewriteCond %{QUERY_STRING} ^$
RewriteCond %{THE_REQUEST} /(.*)index\.php
RewriteRule ^index\.php$ http://%{HTTP_HOST}/%1 [R=301,L]

RewriteRule ^feeds/(1-0|2-0|atom)\.xml$ index.php?t=$1 [L,QSA]
RewriteRule ^sitemap\.xml$ index.php?t=sitemap [L]
RewriteRule ^trackback-([0-9]+)-([0-9]+)-(.+)\.xml index.php?t=trackback&tid=$1&uid=$2&tbid=$3 [L]
RewriteRule ^(.+)-(f|t|u)-([0-9]+)-([0-9]+)$ index.php?o=$2&n=$1&id=$3&p=$4
RewriteRule ^neue-beitraege-([0-9]+)$ index.php?o=p&p=$1
RewriteRule ^sitemap-([0-9]+)$ index.php?o=sitemap&p=$1
RewriteRule ^archiv-([0-9]+)$ index.php?o=t&p=$1
RewriteRule ^userliste-([0-9]+)$ index.php?o=u&p=$1
RewriteRule ^edit/([a-z]+)-([0-9]+)$ index.php?z=edit&o=$1&id=$2 [QSA]
RewriteRule ^new/([a-z]+)$ index.php?z=new&o=$1 [QSA]
RewriteRule ^(admin|mods|suche)$ index.php?z=$1 [QSA]
RewriteRule ^(login|logout)$ index.php?z=$1
RewriteRule ^info/([a-z]+)$ index.php?o=$1 [L,QSA]
RewriteRule ^scripts/bbcode-([0-9]+)-[0-9a-f]{4}\.js$ scripts/bbcode.php?t=js&vars=$1
RewriteRule ^styles/(.+)-v[0-9]+\.css$ styles/$1.css

# Komprimierung von css und js Dateien:
# RewriteRule \.(css|js)$ compress.php

# Die folgenden Zeilen koennen nach erfolgreicher Installation entfernt werden:
RewriteCond %{QUERY_STRING} !mr=
RewriteRule ^install\.php$ install.php?mr=1 [QSA]
RewriteRule ^scripts/install/$ scripts/checkmr.js

Ich benutze übrigens wirklich Filezilla als FTP-Programm und auch den Transfertyp habe ich testweise auf ASCII gestellt, bringt aber auch keine Änderung. Bearbeitet hatte ich die Datei zuvor übrigens mit dem Standard-Editor, welcher Windows beiliegt.

21.12.2013 14:23 | geändert: 21.12.2013 14:24

10 Jörg

Irgendwo gibt es in Notepad++ die Möglichkeit, Windows- in Unix-Umbrüche zu ändern und umgekehrt. Ich habe jetzt nur eine Anleitung für die englischsprachige Version gefunden:

http://www.larshaendler.com/2013/06/10/notepad-unix-to-dos-line-endings/

Probier mal, ob das Konvertieren hilft, und achte dabei darauf, ob dabei an Zeilenenden irgendwelche merkwürdigen Steuerzeichen erscheinen, die du dann rauslöschst.

Oder besser noch: bearbeite mal die Originaldatei aus dem tar.gz Archiv mit Notepad++

Wenn du gar nicht zurande kommst, kannst du mir die Datei auch zusenden.

Bearbeitet hatte ich die Datei zuvor übrigens mit dem Standard-Editor, welcher Windows beiliegt.

Ja, ich vermute mal, dass der da was verhunzt hat

21.12.2013 15:16 | geändert: 21.12.2013 15:20

1 Forenmitglied fand diesen Beitrag gut